Напишите программу, которая вводит натуральное число N и выводит первые N чётных...

0 голосов
689 просмотров

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел. Входные данные Входная строка содержит единственное число – требуемое количество чисел N . Выходные данные Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами. Примеры: входные данные 5 выходные данные 2 4 6 8 10 !!! ЯЗЫК PascalABC !!! !!! Без while, a через for !!!


Информатика (22 баллов) | 689 просмотров
Дан 1 ответ
0 голосов

Var N,i:integer;
begin
read(N);
for i:=1 to N do write(2*i);
end.

(178 баллов)
0

проверь в компиляторе программу, я pascal плохо помню, не уверен в написании

0

Извините пожалуйста, случайно нажала 4 звезды, я не специально. Заслуживаете 5 звезд!) Перед "for" надо было поставить ";", т.е. после "(N)". Спасибо большое)

0

ну, я писал, чтобы помочь, оценка мне не важна.

0

а про ; вспомнил потом, добавил их