Напишите программу, которая вводит натуральные числа a , b и N , и выводит ** экран N...

0 голосов
477 просмотров

Напишите программу, которая вводит натуральные числа a , b и N , и выводит на экран N псевдослучайных целых чисел на отрезке [ a , b ] . Входные данные Входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел N . Гарантируется, что a ≤ b . Выходные данные Программа должна вывести N случайных целых чисел в одной строке, разделив их пробелами. Примеры: входные данные 10 20 5 выходные данные 10 10 19 12 13 !!! ЯЗЫК PascalABC !!! !!! Без while, a через for !!!


Информатика (22 баллов) | 477 просмотров
Дан 1 ответ
0 голосов

var a,b,n,i: integer;


begin


write ('Введите границы отрезка: ');


readln (a,b);


write ('Введите требуемое количество чисел: ');


readln (n);


for i:=1 to n do write(random(b-a+1)+a,'   ')


end.


image
(3.9k баллов)
0

Какие, например, можно ввести числа где написано: "Границы отрезка" и "Введите требуемое количество чисел"? Или так и оставить в программе?

0

Можно вообще убрать строки: "write ('Введите границы отрезка: ');" и "write ('Введите требуемое количество чисел: ');"

0

Прикрепила скриншот PascalABCNET

0

Спасибо большое)