Напишите программу, которая выводит символы с кодами от N до М (в три столбца) Напишите...

0 голосов
27 просмотров

Напишите программу, которая выводит символы с кодами от N до М (в три столбца) Напишите фрагмент задачи, в котором будет определяться символ по своему кодуНапишите фрагмент задачи, в которой будет определяться код символа


Информатика (19 баллов) | 27 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var n,m,i,k:integer; c:char;

begin

// 1

write('n, m: ');

readln(n,m);

k:=0;

for i:=n to m do

begin

write(i,' - ',chr(i),'   ');

k:=k+1;

if k mod 3=0 then writeln;

end;

// 2

write('n: ');

readln(n);

writeln(n,' ',chr(n));

// 3

write('c: ');

readln(c);

writeln(c,' ',ord(c));

end.

Пример:

n, m: 40 60

40 - (   41 - )   42 - *    

43 - +   44 - ,   45 - -    

46 - .   47 - /   48 - 0    

49 - 1   50 - 2   51 - 3    

52 - 4   53 - 5   54 - 6    

55 - 7   56 - 8   57 - 9    

58 - :   59 - ;   60 - <    

n: 100

100 d

c: {

{ 123

(194k баллов)
0

спасибо огромное :)

0

Пожалуйста.