ОЧЕНЬ НАДО 9 КЛАСС ИНФОРМАТИКА (пожалуйста напишите полную программу, лучший ответ...

0 голосов
14 просмотров

ОЧЕНЬ НАДО 9 КЛАСС ИНФОРМАТИКА (пожалуйста напишите полную программу, лучший ответ отмечу!!11!) Написать программу: Заполнить массив из 20 элементов случайными числами на интервале [-20, 25]. Найти произведение элементов с четными номерами.


Информатика (12 баллов) | 14 просмотров
Дан 1 ответ
0 голосов

var a:array [1..20] of integer;

i:integer;

p:real;

begin

p:=1;

for i:= 1 to 20 do

begin

a[i]:= Random(46)-20;

if i mod 2 = 0 then p:=p*a[i]

end;

writeln('Массив: ',a);

writeln('Произведение элементов с чётными номерами равно: ',p);

end.

(3.9k баллов)