Написать задачу ** языке PascalABC По одну сторону улицы находятся дома с нечетными...

0 голосов
84 просмотров

Написать задачу на языке PascalABC По одну сторону улицы находятся дома с нечетными номерами (1,3,5,..), по другую сторону- четными (2,4,6,..). Дом 1 находится напротив дома 2, дом 3- напротив дома 4 и тд. До соседнего дома нужно идти вдоль по улице одну минуту, неважно, с какой стороны улицы он находится (то есть от дома 1 нужно идти одну минуту как до дома 3, так и до дома 4). До дома, стоящего напротив, идти не нужно. Человек вышел на улицу из дома А и должен дойти до дома В. Определите, сколько минут ему нужно идти вдоль по улице. Программа получает на вход два различных целых положительных числа А и В, не превосходящие 2•10(в 9 степени), - номера домов. Программа должна вывести одно число-искомое количестао минут. Пример входных и выходных данных : Ввод : 1 , 8 Вывод: 3


Информатика (23 баллов) | 84 просмотров
Дан 1 ответ
0 голосов

begin


var a:=ReadInteger;


var b:=ReadInteger;


var min:=0.0;


for var i:=a to b do


begin


min+=0.5;


end;


If odd(a) and not odd(b) then


write(min-1);


If not odd(a) and odd(b) then


write(min);


If (not odd(a) and not odd(b)) or (odd(a) and odd(b)) then


write(min-0.5);


end.

Вроде так, но не уверен!

(168 баллов)
0

ну как?

0

Ещё не проверял, но в любом случае спасибо. Хотя бы приблизительно буду знать

0

Вряд ли пройдет все тесты, если автоматика. Решение кривое, половинчатое. В условии не сказано, что всегда B>A, а для случая движения по улице от домов со старшими номерами к младшим программа выдает ерунду.

0

Хм, что там тогда будет ?

0

Числа типа 0, -0.5 и т.п. )))