Напишите программу, условие задачи в приложении
begin
var n := ReadInteger;
var m := Max(n div 10, n mod 10);
m *= 11;
if m < n then Println('NO')
else Println(m - n)
end.
var a:integer;
readln (a);
if a div 10 = a mod 10 then write ('NO') else
if a div 10 > a mod 10 then write ((a div 10 + a div 10*10)-a)
else write ((a mod 10 + a mod 10*10)-a);
спасибо большое, все работает
вы не могли бы подумать еще над этой задачей, если сможете https://znanija.com/task/30194711 заранее спасибо!
Вопрос: почему для двух одинаковых цифр у Вас выдается NO? По условию увеличивать можно на любое НЕОТРИЦАТЕЛЬНОЕ число. В данном случае увеличить надо на ноль, а ноль число не отрицательное, значит ответ 0.
спасибо за поправку
но тогда в каком случае вообще возможен ответ NO
Я вообще не смог придумать случай, когда будет NO )))
Ну что же, обычное дело: кривое условие. Не впервой)))
понятно, спасибо)))
Это олимпиады - из из года в год с одними и теми же кривыми условиями переписывают