Составить программу. Вывести на экран 10 первых целых чисел кратных 7 pascal. Если правильно дам ещё баллы.
var a,i:integer;
begin
for a:=14 to 77 do
if (a mod 7=0) then
write(a,' ');
end;
end.
var i,k:integer;
repeat
if i mod 7 = 0 then
k:=k+1;
write (i,' ')
i:=i+1
until k=10
Так короче программа: var k,n: integer;begin repeat n:=n+7; write(n,' '); k:=k+1; until k=10; end.
beginwrite (0,' ',7,' ',14,' ',21,' ',28,' ',35,' ',42,' ',49,' ',56,' ',64)end.
Так ещё короче... )))
А если k = 10000, то как со временем выполнения программы при использовании mod?
Пример задачи, где время выполнения существенно, task/30211291.
А если надо выбрать числа кратные 7 из произвольного набора чисел?
Тогда это уже другая задача.
Извините, но так и не поняла, зачем вы презентовали свой вариант программы... Либо вы точно знаете какие числа нужны и тогда непонятен выбор именно данного цикла, либо устраивать проверку на кратность и не придумывать мифические условия...
Ведь можно писать и так:beginSeqGen(10, 0, t -> t + 7).Printend.
Это уже на паскаль, а PascalABC.NET, а опубликовал - для разнообразия.