СРОЧНО ХЕЛП!!!!!Напишите программу для решение задачи с клавиатуры вводится целое число...

0 голосов
79 просмотров

СРОЧНО ХЕЛП!!!!!Напишите программу для решение задачи с клавиатуры вводится целое число от 1 до 99 если число2-значное ,то вывести кол-во десятков в числе,иначе вывести введенное число увеличенное на 1 с помощью dif и mod Paskal


Информатика (20 баллов) | 79 просмотров
Дан 1 ответ
0 голосов

Var a:integer;
Begin
read(a);
If a>10 then a:= a div 10
else a:= a+1;
writeln(a);
end.

(18 баллов)
0

Можно написать даже "if a>9" чтобы 10 тоже включалось в условие