Напишите программу в Паскале, которая заполняет массив из N =10 элементов случайными...

0 голосов
233 просмотров

Напишите программу в Паскале, которая заполняет массив из N =10 элементов случайными числами в диапазоне [0;20] и сортирует его в порядке убывания


image

Информатика (28 баллов) | 233 просмотров
0

Нужна какая-то конкретная сортировка или не важно как, но чтобы сортировалось? Алгоритм сортировки выписывать?

0

begin var a := ArrRandom(10, 0, 20); a.Println; a := a.OrderDescending.ToArray; a.Println;end.

Дан 1 ответ
0 голосов

const

  n = 10;

  x = 1;

  y = 20;

   

var

  arr: array[1..n] of integer;

  tmp: integer;

   

begin

  randomize;

   

  write('Массив: ');

   

  for var m := 1 to n do

  begin    

     arr[m] := random(x, y);

     write(arr[m], ' ');

  end;

     

  for var i := 1 to n do

  begin

     for var j := 1 to n - 1 do

     begin

        if (arr[j] < arr[j + 1]) then

        begin

           tmp := arr[j];

           arr[j] := arr[j + 1];

           arr[j + 1] := tmp;

        end;

     end;

  end;      

   

  writeln();

  write('После сортировки: ');

   

  for var i := 1 to n do

     write(arr[i], ' ');

end.


image
(13.4k баллов)