Написать программу ** Паскале: Дана S круга. Найти его диаметр D и длину L окружности,...

0 голосов
44 просмотров

Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π×D, S = π×D2(в квадрате) /4


Информатика (16 баллов) | 44 просмотров
Дан 1 ответ
0 голосов

const

 pi = 3.14;

var

 S, D, L: real;

begin

 write('Введите площадь круга: S = ');

 readln(S);

 D := 2 * sqrt(S / pi); {

 L := pi * D; {

 writeln('Результат:');

 writeln(' D = ', D:0:2); {

 writeln(' L = ', L:0:2); {

 readln

end.

(23 баллов)