Напишите программу в Pascal ABC, пожалуйста
Вы тогда еще указывайте, где его брать.
Поскольку с 2007 года разработчики его не поддерживают.
var z,x: integer; y: real;
begin
readln(z,x);
if (x>=3) then y:=sqr(z) else
if ((z>0) and (x>0)) then y:=sqrt(sqr(z)) else
if (x
writeln(y);
end.