Вычислить сумму чисел от 1 до 100 которые делятся ** 3 написать программу для...

0 голосов
55 просмотров

Вычислить сумму чисел от 1 до 100 которые делятся на 3 написать программу для вычисления(паскаль)


Информатика (32 баллов) | 55 просмотров
0

На каком языке программирования?

0

паскаль

Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1847 от 28.10.2018

Внимание! Если программа не работает, обновите версию!

begin

 3.Step(3).TakeWhile(t -> t <= 100).Sum.Println</p>

end.

1683

(654k баллов)
0 голосов

2 варианта

var s,i: integer;

begin

s:=0;

i:=3;

while (i

begin

s:=s+i;

inc(i,3);

end;

writeln('Сумма чисел, которые делятся на 3: ',s);

readln;

end.

___________________________________________________

var s,i: integer;

begin

s:=0;

for i:=1 to 100 do if (i mod 3 = 0) then s:=s+i;

writeln('Сумма чисел, которые делятся на 3: ',s);

readln;

end.


Выбирайте на свой вкус

(552 баллов)