Составьте программу, которая по номеру семестра печатает курс, к которому относится...

0 голосов
162 просмотров

Составьте программу, которая по номеру семестра печатает курс, к которому относится введенный семестр (1 и 2 семестр – 1 курс, 3 и 4 семестр – 2 курс и т. д.) 3) Для каких из приведённых чисел ложно высказывание: НЕ (число > 50) ИЛИ (число чётное)? Выберите правильные ответы: 123 50 9 8 97


Информатика (1.0k баллов) | 162 просмотров
Дан 1 ответ
0 голосов

1.

Код (Pascal)

var

 x: integer;


begin

 read(x);

 writeln((x + 1) div 2);

end.

--------------------

Прикреплён во вложениях.


2.

Давай "перевернём" условие с "НЕ" для понимания:

НЕ (число > 50) = (число <= 50)</p>

  1. Рассмотрим число 123. Для него не выполняется условие НЕ (123 > 50) и не выполняется условие (123 чётное). Высказывание ложно, число подходит.
  2. Рассмотрим число 50. Для него выполняется условие НЕ (50 > 50). Высказывание истинно, число не подходит.
  3. Рассмотрим число 9. Для него выполняется условие НЕ (9 > 50). Высказывание истинно, число не подходит.
  4. Рассмотрим число 8. Для него выполняется условие НЕ (8 > 50). Высказывание истинно, число не подходит.
  5. Рассмотрим число 97. Для него не выполняется условие НЕ (97 > 50) и не выполняется условие (97 чётное). Высказывание ложно, число подходит.

Ответ: 123 97

(3.7k баллов)