Написать программу ** c++, где пользователь вводит своё ФИО, а программа выдаёт...

0 голосов
141 просмотров

Написать программу на c++, где пользователь вводит своё ФИО, а программа выдаёт количество символов, которые пользователь ввёл с клавиатуры


Информатика (24 баллов) | 141 просмотров
0

Сначала имя, затем фамилию и имя? Или все в одну переменную?

0

Все кроме пробела?

Дан 1 ответ
0 голосов

/*В комментария вы сказали, что нужно считать не все символы строки (не считать пробел), что я и отразил в коде. Если понадобится считать все символы строки, то можно обойтись без цикла, а сделать так: cout << "Symbols: " << fio.length();).*/</p>

#include

using namespace std;

int main()

{

   string fio;

   int counter = 0;

   cout

   getline(cin, fio);

   for (int i = 0; i < fio.length(); i++)

   {

       if (fio[i] != ' ')

           counter++;

   }

   cout

   return 0;

}


image
image
(13.4k баллов)