Напишите программу, которая заполняет массив из N элементов случайными целыми числами в...

0 голосов
152 просмотров

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое всех элементов этого массива, которые меньше 50, и среднее арифметическое всех остальных элементов.


Информатика (18 баллов) | 152 просмотров
0

с++

Дан 1 ответ
0 голосов

#include
#include

using namespace std;

int main(){
srand(time(NULL));
int n;
cout << "Vvedite N << endl;<br>cin >> n;
int arr[n];
int a,b;
cout << "Vvedite diapozon A-B cherez probel" << endl;<br>cin >> a >> b;
for (int i=0; iint s50 = 0;
int ss50 = 0;
int s = 0;
int ss = 0;
for (int i=0; iif (a[i]<50) {<br>s50+=a[i];
ss50++;
} else {
s+=a[i];
ss++;
}
}
cout << "Srednee arifmeticheskoe chisel menshe 50 ravno " << s50/ss50 << endl;<br>cout << "Srednee arifmeticheskoe chisel ostalnix elementov ravno " << s/ss;<br>return 0;
}

(552 баллов)