Напишите программу в Pascalсергей страдает ожирением в процессе голадания он каждую...

0 голосов
42 просмотров

Напишите программу в Pascalсергей страдает ожирением в процессе голадания он каждую неделю скидывает 3%от предыдущего веса, изночально он весил 150кг в машину он влезет когда будет весить 97кг Через сколько недель он влезет в машину?


Информатика (27 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

PROGRAM zhirobas;

VAR  

MASSA:REAL;

NED:INTEGER;

BEGIN

MASSA:=150;

NED:=0;

WHILE (MASSA>=97) DO

BEGIN

MASSA:=MASSA-MASSA*0.03;

NED:=NED+1;

END;

WRITELN('Через ',NED,' недель Сергей влезет в машину')

END.

(86 баллов)