Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и...

0 голосов
1.4k просмотров

Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года», «25 лет». Пример:Введите возраст: 18 Вам 18 лет. Пример:Введите возраст: 21Вам 21 год. Пример:Введите возраст: 22Вам 22 года.На C++ или Паскаль


Информатика (12 баллов) | 1.4k просмотров
0

function Склонение_после_числительного(ч, с1, с2, с3) { return (ч % 100 >= 5 && ч % 100 <= 20) ? с3 : ((ч % 10 == 1) ? с1 : ((ч % 10 >= 2 && ч % 10 <= 4) ? с2 : с3)); }

0

Расписывать это в виде программки на C++ мне лень, бери JS.

0

На каком языке?

Дан 1 ответ
0 голосов

program Vozrasr;



var


 AGE: integer;//Переменная возраста



begin


 writeln('Введите любое число от 1 до 120');


 Readln(AGE); //Ввод возраста


 if (AGE < 1) or (AGE > 120) then


begin


   writeln('ERROR!')


end


 else


 begin


   case AGE of  //для чисел от 11 до 20 создаем отд-ый кейс


     11..20: Writeln('Ответ: Мне ', AGE, ' лет');


   Else    //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс


     begin


       case AGE mod 10 of     //делим на 10 и получаем остаток =


         1: Writeln('Ответ: Мне ', AGE, ' год');


         2..4: Writeln('Ответ: Мне ', AGE, ' года');


         0, 5..9: Writeln('Ответ: Мне ', AGE, ' лет');


       end;


     end;


   end;


end;


end.

(141 баллов)
0

написал на paskal