ПАСКАЛЬ Напишите программу, которая заполняет массив из N элементов в обратном порядке...

0 голосов
148 просмотров

ПАСКАЛЬ Напишите программу, которая заполняет массив из N элементов в обратном порядке последовательными натуральными числами, начиная с последнего элемента, который должен быть равен X . Входные данные Входная строка содержит два целых числа: начальное значение X и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести содержимое массива: убывающую последовательность из N последовательных натуральных чисел; последний элемент должен быть равен X . Примеры входные данные 6 4 выходные данные 9 8 7 6


Информатика (29 баллов) | 148 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var (x, n) := ReadInteger2;

 var a := ArrGen(n, n + x - 1, t -> t - 1);

 a.Println

end.

6 4

9 8 7 6

(654k баллов)
0 голосов

var a:array[1..10000] of integer;

x,n,i: integer;

begin

readln(x,n);

for i:=1 to n do a[i]:=x+n-i;

for i:=1 to n do write(a[i],' ');

writeln;

end.

Пример:

6 4

9 8 7 6

(194k баллов)