Дана матрица С(n×n) и вектор а(a1,a2,a3,...,an).Написать программу вычисления вектора...

0 голосов
64 просмотров

Дана матрица С(n×n) и вектор а(a1,a2,a3,...,an).Написать программу вычисления вектора b=C*a.В Паскале .


Информатика (12.2k баллов) | 64 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018

Внимание! Если программа не работает, обновите версию!

uses NumLibABC;


begin

 var n := ReadInteger('n=');

 Println('Введите построчно элементы матрицы С');

 var C := new Matrix(n, n, ReadArrReal(n * n));

 Println('Введите элементы вектора a');

 var a := new Vector(ReadArrReal(n));

 var b := C * a;

 Println('Полученный вектор b');

 b.Println

end.


image
(654k баллов)
0

Можно вводить и нецелые значения.

0 голосов

const n=5;

var c:array[1..n,1..n] of integer;

a, b: array[1..n] of integer;

i, j, s: integer;

begin

Randomize;

writeln('Исходный массив С:');

for i:=1 to n do

begin

for j:=1 to n do

 begin

  c[i,j]:=random(10);

  write(c[i,j]:4);

 end;

 writeln;

end;

writeln('Исходный массив a:');

for i:=1 to n do

 begin

  a[i]:=random(10);

  write(a[i]:4);

 end;

 writeln;

for i:=1 to n do

begin

s:=0;

for j:=1 to n do s:=s+c[i,j]*a[j];

b[i]:=s;

end;

writeln('b=C*a');

for i:=1 to n do write(b[i]:4);

 writeln;

end.

Пример:

Исходный массив С:

  3   9   2   3   5

  3   9   5   6   9

  9   2   1   7   8

  5   2   0   3   2

  8   6   6   1   3

Исходный массив a:

  8   6   9   1   7

b=C*a

134 192 156  69 176

(194k баллов)