Написать программу которая будет определять делится ли число ** 11 по признаку делимости...

0 голосов
20 просмотров

Написать программу которая будет определять делится ли число на 11 по признаку делимости на 11 на С++


Информатика (12 баллов) | 20 просмотров
Дан 1 ответ
0 голосов

#include


using namespace std;


int main(){

   int n;

   cout<<"n = ";</p>

   cin>>n;

   

   int m=n,k=0;

   while(m){

       k++;

       m=m/10;

   }

   

   int arr[k];

   m=n;

   for(int i=0;i

       arr[i]=m%10;

       m=m/10;

   }

   

   int chet=0,nechet=0;

   for(int i=k-1;0<=i;i=i-2){</p>

       nechet=nechet+arr[i];

   }

   

   for(int i=k-2;0<=i;i=i-2){</p>

       chet=chet+arr[i];

   }

   

   if((chet==nechet)||(chet-nechet==11)||(chet-nechet==-11))

       cout<<"n%11=0"<<endl;</p>

   else

       cout<<"n%11!=0"<<endl;</p>

}

(38 баллов)
0

не влияет абсолютно

0

Вот и закончим на этом диалог.

0

не стоило его и начинать

0

Ну, если честно то ваш код не переносим и например в msvc он не запустится.

0

А Вы почему перестали писать ответ?)) Я бы на Ваш код посмотрел.

0

Я думал здесь в редакторе написать, но ультра не удобно, а что-то лишнее открывать мне лень)

0

Онлайн-компиляторы в помощь ))

0

Вспомнил о них когда закрыл уже вопрос. Ну, тем более там же элементарно циклом, без массиовов number%10, number/=10

0

И это в int sum какой-то пишем