Составить программу поиска больших чем соседние элементов массива L из 16 чисел. Значения...

0 голосов
58 просмотров

Составить программу поиска больших чем соседние элементов массива L из 16 чисел. Значения элементов массива рассчитать по формуле CosD/D,где D номер элемента массива.


Информатика (12 баллов) | 58 просмотров
Дан 1 ответ
0 голосов
VAR
   i: Integer;
   a: Array [1..16] of Real;
BEGIN
    For i := 1 to 16 do begin
        a[i] := Cos(i) / i;
        Writeln('L[',i,'] = ',a[i]); End;

    Writeln;
    For i := 2 to 15 do
        If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.
(733 баллов)