Программа ** паскале. Помогите, пожалуйста! Ряд чисел Фибоначчи задается следующим...

0 голосов
139 просмотров

Программа на паскале. Помогите, пожалуйста! Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F i = F i - 1 + F i - 2 . Напишите программу, которая вводит натуральное число N и выводит первые N чисел Фибоначчи. Входные данные Входная строка содержит натуральное число N – количество нужных чисел Фибоначчи. Выходные данные Программа должна вывести в одной строке первые N чисел Фибоначчи, разделив их пробелами.


Информатика (5.6k баллов) | 139 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

...А если интересует решение на классическом Паскале, предлагаю просто поддерживать текущее, предыдущее и пред-предыдущее значения в ряду, и в цикле обновлять ответ.

Обрати внимание! longint может хранить значения только до 2^{31}-1, поэтому конкретно в этой программе вывод будет достоверным только для N ≤ 46. Ты можешь сделать текущую, предыдущую и пред-предыдущую переменные типа int64, и тогда максимальное значение N возрастёт до 92. Для бОльших N тебе придётся писать длинное сложение.


Код

var

i, n, pred, predpred, cur: longint;

begin

read(n);

if n = 1 then writeln(1)

else if n = 2 then writeln('1 1')

else write('1 1 ');

if n < 3 then exit;

pred := 1;

predpred := 1;

for i := 3 to n do

begin

 cur := pred + predpred;

 write(cur, ' ');

 predpred := pred;

 pred := cur;

end;

writeln;

end.

(3.7k баллов)
0

Под Free компилируете?

0

Какие-то проблемы с компиляцией. Но ладно, все равно спасибо

0

Работает?

0

Да

0

Сейчас проверю

0

Это решение запускается на PascalABC.Net, но необязательно новейших версий. Проблема в функции min - в FPC она не встроена. Сейчас попрошу отправить на доработку.

0

Исправлено. FPC 3.0.4 компилируется и запускается без ошибо.

0

Да, я вспомнила, как раз из-за min не работала

0

Благодарю за исправление)

0 голосов

PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 SeqGen(ReadInteger, 1, 1, (i, j)-> i + j).Println

end.


И это - всё !


image
(654k баллов)
0

развития системы образования*

0

Раньше можно было в личке общаться, теперь это закрыли. Вот и захламляем ((

0

Но я жил в свое время в Минске полгода, я знаю, что эти люди могут, когда захотят. Москва, Киев, Новосибирск, Минск, Казать и Ереван еще в советское время были научными и прозводственно-техническими центрами в радиопромышленности по линии вычтехники и софта

0

2GIAMMY: вчера в РАВС переименовали генератор для вещественных последовательностей. Его теперь зовут PatritionPoints вместо Patrition,

0

Не слушайте, я же Вас не неволю. Кстати, мне тоже "за 65".

0

Что-то мы уже уходим в даль, давайте не будет захламлять комменты)

0

Если смотреть на это все со стороны, то я тоже сейчас слушаю "кого-то" (вас). Думаете, преподаватель, которому за 65, не знает, как там жилось?)

0

Конечно, тогда не было мобильников, пепси и жвачек. Но Вам вряд ли можно объяснить, что вы на них сейчас променяли.

0

Ну видите ли, Вы об этом слушаете кого-то, а я тогда жил, учился и работал.

0

Советское время, хех)Нам каждую лекцию по микроэлектронике распинаются о том, как хорошо всё было тогда)