Помогите написать программу в паскале. Ввести N чисел. Найти первое максимальное число и...

0 голосов
28 просмотров

Помогите написать программу в паскале. Ввести N чисел. Найти первое максимальное число и его номер.


Информатика (15 баллов) | 28 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := ReadArrReal('Вводите:', ReadInteger('Количество чисел?'));

 var imax := a.IndexMax;

 Writeln('Первое максимальное число ', a[imax],

     ' имеет номер ', imax + 1)

end.

Пример

Количество чисел? 5

Вводите: 14 2.17 15.2 8 15.2

Первое максимальное число 15.2 имеет номер 3

(654k баллов)
0 голосов

var n,i,m,k,a: integer;

begin

write ('Введите количество чисел: ');

readln (n);

write ('Введите число: ');

readln (a);

m:=a;

k:=1;

for i:=2 to n do

begin

write ('Введите число: ');

readln (a);

if a>m then

begin

m:=a;

k:=i

end

end;

writeln ('Первый максимальный элемент ',m,' и его номер ',k)

end.

(3.9k баллов)