Напишите программу которая заполняет матрицу размером 7 7 случайными числами а затем...

0 голосов
239 просмотров

Напишите программу которая заполняет матрицу размером 7 7 случайными числами а затем записывает в элементы отмеченные на рисунках серым фоном число 99


image

Информатика (12 баллов) | 239 просмотров
Дан 1 ответ
0 голосов

program shegor2003;

var a:array[1..7,1..7] of integer;

i,j:integer;

begin

for i:= 1 to 7 do

for j:= 1 to 7 do

a[i,j]:=random(101)-50;

writeln('Исходный массив:');

for i:= 1 to 7 do begin

 for j:= 1 to 7 do

   write(a[i,j]:4);

 writeln;

 end;

for i:= 2 to 6 do

for j:= 2 to 6 do

if i+j<=8 then  </p>

a[i,j]:=99;

writeln; writeln('Преобразованный массив:');

for i:= 1 to 7 do begin

 for j:= 1 to 7 do

   write(a[i,j]:4);

 writeln;

 end;

end.




image
(52.6k баллов)