Помогите срочно написать программу в паскале.номер 7.даю 50 баллов

0 голосов
13 просмотров

Помогите срочно написать программу в паскале.номер 7.даю 50 баллов


image

Информатика (325 баллов) | 13 просмотров
0

Задание составлено с ошибками. Т.е. логически понятно, что некорректное оно.

0

Ну не может быть, что хоть 1 кВт израсходовал, хоть 100, все равно 2 руб оплата. Это явно цена за каждый кВт.

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018

// Внимание! Если программа не работает, обновите версию!

1) точно по заданию

begin

 var k := ReadInteger('k=');

 Writeln('К оплате, руб: ', 2.0 + (k > 100 ? (k - 100) * 2.5 : 0.0))

end.

2) по логике так должно быть

begin

 var k := ReadInteger('k=');

 if k <= 100 then Writeln('К оплате, руб: ', 2.0 * k)</p>

 else Writeln('К оплате, руб: ', 200.0 + (k - 100) * 2.5)

end.

(654k баллов)