Составьте программу, которая формирует массив из 15 случайных целых чисел от -20 до 20 и...

0 голосов
12 просмотров

Составьте программу, которая формирует массив из 15 случайных целых чисел от -20 до 20 и четные числа делит на 2, а нечетные умножает на 3 PascalABC


Информатика (23 баллов) | 12 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;

var a: array[1..15] of integer;

i: integer;

begin

write('исходный массив: ');

for i:=1 to 15 do begin

a[i]:=random(41)-20;

write(a[i],' ');

end;

writeln;

write('полученный массив: ');

for i:=1 to 15 do begin

if a[i] mod 2=0 then a[i]:=trunc(a[i]/2) else a[i]:=a[i]*3;

write(a[i],' ');

end;

end.

(149k баллов)