Напишите программу, которая создаёт и выводит массив из действительных чисел случайным...

0 голосов
67 просмотров

Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4 до 10 строк и столбцов, затем через пустую строку выводит тот же массив, но выводит его столбец так, чтобы поменялся местами с последним.


Информатика (15 баллов) | 67 просмотров
0

Какой именно столбец должен меняться с последним местами?

0

второй столбец на последний

Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := (Random(4, 10), Random(4, 10));

 Writeln('*** Исходный массив ***');

 var a := MatrRandomReal(m, n, -99, 99);

 a.Println(8, 3);

 Writeln('*** Полученный массив ***');

 a.SwapCols(1, a.ColCount - 1);

 a.Println(8, 3)

end.


image
(654k баллов)
0

спросите*

0

учителя ))

0

Ну если Вы не можете написать это, то не заслуживаете никаких пятерок.

0

Более того, Вы даже не удосужились указать в вопросе даже язык программирования, не говоря о его конкретном диалекте.

0

такую чушь пишут только на паскале

0

абс

0

А теперь свой ляп пытаетесь исправить, уговаривая ответившего делать работу еще раз

0

"такую чушь пишут только на паскале" - такие глупости пишут только недалекие детишки.

0

Все, мне надоело читать эту ерунду.

0

кем вы работаете?