Прошу помощи по информатике. Требуется написать программу ** паскале по этой формуле min...

0 голосов
26 просмотров

Прошу помощи по информатике. Требуется написать программу на паскале по этой формуле min (ab, ac, bc) (это нахождение наименьшего значения, как я понимаю). Прошу помочь (я гуманитарий).


Информатика (20 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

var a,b,c:integer;

begin

readln(a);readln(b);readln(c);

if (a*b < a*c)and (a*b < b*c)then

writeln(a*b)else

if (a*c < a*b)and (a*c < b*c)then

writeln(a*c)else writeln(b*c);

end.


(57 баллов)
0

Выдаёт цифру 2, а не нужное мне выражение

0

программа выдает минимальное произведение

0

var a,b,c:integer;beginreadln(a);readln(b);readln(c);if (a*b < a*c)and (a*b < b*c)thenwriteln(a,'*',b)elseif (a*c < a*b)and (a*c < b*c)thenwriteln(a,'*',c)else writeln(b,'*',c);end.так надо?

0

Вот ещё нужно. Дополнить программу следующим фрагментом. Определить, принадлежит ли вычисленное значение максимума (минимума) интервалу [0.5; 2.0] и выдать на экран соответствующее сообщение. Отладить и выполнить программу с произвольными значениями входных данных

0

так максимума или минимума?

0

минимума

0

ок

0

var a, b, c: real;begin readln(a);readln(b);readln(c); if (a * b < a * c) and (a * b < b * c) then begin writeln(a, '*', b); if (a * b <= 2) and (a * b >= 0.5) then writeln('YES') else writeln('NO'); end else if (a * c < a * b) and (a * c < b * c) then begin writeln(a, '*', c); if (a * c <= 2) and (a * c >= 0.5) then writeln('YES') else writeln('NO'); end else begin writeln(b, '*', c); if (b * c <= 2) and (b * c >= 0.5) then writeln('YES') else writeln('NO'); end;end.

0

так?