Составьте программу, которая заменяет все буквы "о" ** символ "*" в строке s.

0 голосов
64 просмотров

Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s.


Информатика (24 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
var 
s: string;
i: integer;

begin
write('Введите строку: ');
read(s);
for i:= 1 to length(s) do 
 case s[i] of 
  'о': s[i]:='*'; 
  'О': s[i]:='*'; 
 end;

writeln('Результат: ',s); 
end.
(1.4k баллов)
0

Спасибо большое. Программа работает. Но моя вина в том, что я не уточнила одну вещь - использовать можно только функции и процедуры: delet, insert, pos, setlength. Можно ли как-то составить программу, исходя из этих только функций?

0

То есть не обязательно будут использоваться ВСЕ эти функции, но одна из этих функций delet, insert, pos, setlength, length может использоваться. И никакие больше...