90 баллов Напишите программу для определения имеет ли женщина идеальный вес. Значения...

0 голосов
42 просмотров

90 баллов Напишите программу для определения имеет ли женщина идеальный вес. Значения роста и фактического веса вводится с клавиатуры.Программа вычисляет идеальный вес женщин по формуле. Ид.вес=Рост в см-100-10%(170-100) Затем спрашивает вычисленный идеальный вес женщины с фактическим,и дает заключение является ли фактический вес человека идеальным или нет. Паскаль.


Информатика (41 баллов) | 42 просмотров
0

Можно формулу поточнее?

0

И вообще алгоритм поточнее)

0

рост(см)-100-10%

Дан 1 ответ
0 голосов

program MassaProg;

uses crt;

 var factmassa, heigth: integer;

 var massa: real;

begin

 writeln('Vvedite rost v santimetrah: ');

 readln(heigth);

 writeln('Vvedite ves: ');

 readln(factmassa);

 massa:=heigth-100-0.1*(170-100);

if massa = factmassa

 then writeln('Vash ves idealnii') else writeln('Vash ves ne idealnii');

end.

(686 баллов)
0

Эт как класс