СРОЧНО!!!!!!!!!! можете написать программу выводящую ** экран строку матрицы сумма...

0 голосов
172 просмотров

СРОЧНО!!!!!!!!!! можете написать программу выводящую на экран строку матрицы сумма элементов в которой максимальна на Python


Информатика (16 баллов) | 172 просмотров
Дан 1 ответ
0 голосов

import random as r

def function(n, m):

   matrix = [[r.randint(0, 100) for x in range(n)] for y in range(m)]

   max_sum = []

   for q in matrix:

       max_sum.append(sum(q))

       print("{} -- {}".format(q, sum(q)))

   id_max_el = max_sum.index(max(max_sum))

   print(

       "\nСтрока матрицы сумма элементов в которой максимальна -- {}".format(

           matrix[id_max_el]))

z = int(input("Сколька столбцов?: "))

c = int(input("Сколька строк?: "))

function(z, c)


(1.8k баллов)