Напишите программу, которая решает задачу: «Дано целое число n. Вывести ** экран...

0 голосов
143 просмотров

Напишите программу, которая решает задачу: «Дано целое число n. Вывести на экран следующее за ним четное число». ДАЮ 12 БАЛЛОВ


Информатика (34 баллов) | 143 просмотров
Дано ответов: 2
0 голосов

#include
using namespace std;
int main() {

int n, i;

cin >> n;
i = n + 1;

if ( i % 2 == 0) {
cout << i;<br>}
else {
cout << n + 2;<br>}
return 0;
}

не оч красиво, но работает


(424 баллов)
0

Это Питон?

0

это с++

0 голосов

var n:integer;

begin

readln (n);

if n mod 2 = 0 then write(n+2)

else write(n+1)

end.

(1.7k баллов)
0

Это Питон?

0

нет

0

А в Питоне можно?

0

n = int (input())if n % 2 == 0: print (n + 2)else: print (n +1)

0

Это

0

Про Питон надо указывать в вопросе!

0

За верность Питона не ручаюсь...