Дано натуральное 4-х значное число. Напишите программу, которая считает и выводит ответ...

0 голосов
30 просмотров

Дано натуральное 4-х значное число. Напишите программу, которая считает и выводит ответ на вопрос получает новое ЧИСЛО, содержащие цифры первоначального числа, записанные в обратном порядке и вывести это ЧИСЛО на экран и сумму изначально заданного числа и и полученного числа.


Информатика (23 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

program t;

var n, n2, s: integer;

begin

readln(n);

n2:=(n mod 10)*1000+(n div 10 mod 10)*100+(n div 100 mod 10)*10+(n div 1000);

s:=n+n2;

writeln(n2);

writeln(s)

end.

(148 баллов)