Нужна помощь! С помощью операторов div и mod написать программу в Паскале. ** вход-...

0 голосов
51 просмотров

Нужна помощь! С помощью операторов div и mod написать программу в Паскале. На вход- трехзначное число. На выход- вывести на экран количество сотен, десятков и единиц в этом числе.


Информатика (18 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Program N1;

var a,c1,c2,c3: integer;

begin

 writeln('Введите число');

 read(a);

 c1:=a mod 10;

 c2:=(a div 10) mod 10;

 c3:=(a div 100) mod 10;

 writeln('Кол-во сотен = ',c3);

 writeln('Кол-во десятков = ',c2);

 writeln('Кол-во единиц = ',c1);

end.

(86 баллов)