50 БАЛЛОВ Пожалуйста помогите с решением информатики 1. Написать программу которая...

0 голосов
26 просмотров

50 БАЛЛОВ Пожалуйста помогите с решением информатики 1. Написать программу которая считает сумму 2ух введённых чисел и выводит результат на экран; 2. Дана следующая функция, написать программу которая находит значение функции по переданному Х. Использовать оператор ветвления if, then, else. Результат вывести на экран: Дана следующая функция: y = f (x): y = x - 6, если х > 0 y = 32x - 7, если x = 0 y = 5 x - 2, если х < 0 3. Написать программу которая инициализирует массив с 50 значениями, начиная с 1 и поэлементно заполняет его. Результат вывести на экран. Использовать при написании цикл с параметром.


Информатика (14 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

1)

var a,b:longint;

begin

readln(a,b);

writeln(a+b);

end.

2)

var x:longint;

begin

readln(x);

if(x>0) then writeln(x-6) else if(x=0) then writeln(32*x-7) else if(x

end.

3) В третьей условие не совсем понял, если что, дополни, отредактирую код. Какие значения принимают элементы (по какому принципу заполняется массив)? Написал для массива с элементами от 1 до 50.

var a:array[1..50] of integer;

var i:integer;

begin

for i:=1 to 50 do a[i]:=i;

for i:=1 to 50 do writeln(a[i]);

end.


(1.9k баллов)