Что-то подзабыл я pascal. Помогите написать программу в pascal, которая складывает последние 4 цифры любого задаваемого числа.
Var a,s:integer; begin repeat readln(a) until a>9; // по условию число >9 s:=a mod 10; // забираем последнюю цифру while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число writeln(s+a mod 10) // теперь выводим сумму end.
и в каком же месте тут сумма последних 4 цифр числа?
уже сам сообразил. ваша программа не корректна
это сумма первой и последе
а вопрос бы последние 4
насчёт последних не сообразила