Напишите программу ** Паскале, которая вводит и печатает массив из 10 целых чисел, вводит...

0 голосов
28 просмотров

Напишите программу на Паскале, которая вводит и печатает массив из 10 целых чисел, вводит целое число К и выводит номер элемента массива, который равен числу К или выводит 0, если в массиве нет числа, равного К.Даю 20 баллов


Информатика (12 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Program fantscrin;

 Var a: array [1..10] of integer;

     i,k,g:integer;

Begin

 for i:=1 to 10 do

   readln(a[i]);

 for i:=1 to 10 do

   write(a[i], '  ');

 

 writeln('');

 write('К = '); readln(k);

 g:=0;

 for i:=1 to 10 do

   if(a[i] = k) then g:=i;

   

 writeln(g);

End.

(832 баллов)