Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть...

0 голосов
56 просмотров

Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р


Информатика (30 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a: real;
  
begin
  while a <= 1000 do<br>  begin
    writeln('Введите сумму покупки > 1000р');
    readln(a);
    if a > 1000 then break
    else writeln('Ошибка! Введенная сумма покупки <= 1000p');<br>  end;
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
  a: real;
  
begin
  writeln('Введите сумму покупки > 1000р');
  readln(a);
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.

(2.1k баллов)
0

БОЛЬШУЩИЕ СПАСИБИЩЕ!!!

0

:*