Задано целое число n напишите программу которая находит количество 0 в заданном числе.C++

0 голосов
20 просмотров

Задано целое число n напишите программу которая находит количество 0 в заданном числе.C++


Информатика (19 баллов) | 20 просмотров
Дан 1 ответ
0 голосов

#include "iostream"

#include "stdlib.h"

#include "locale.h"

using namespace std;

int main(){

setlocale(LC_ALL, "russian");

int number; // число

int counter = 0; // количество 0

cout << "Введите число: "; cin >> number;

while(number > 10){

 if(number % 10 == 0){

 counter ++;

 }

 number /= 10;

}

cout

system("pause");

return 0;

}


(3.4k баллов)