Напишите программу которая заполняет массив из 20 элементов случайными числами ** отрезке...

0 голосов
682 просмотров

Напишите программу которая заполняет массив из 20 элементов случайными числами на отрезке на отрезке [50;150] и находит в нём минимальные и максимальные элементы и их номера. ДАЮ 50 БАЛЛОВ


Информатика (16 баллов) | 682 просмотров
Дан 1 ответ
0 голосов

const n=20;

var a:array [1..n] of integer;

i,max,maxi,min,mini:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

maxi:=1;

min:=a[1];

mini:=1;

for i:= 1 to n do

begin

if a[i]>max then

begin

max:=a[i];

maxi:=i

end;

if a[i]

begin

min:=a[i];

mini:=i

end

end;

writeln;

writeln('Максимальный элемент ',max,' и его номер ',maxi);

writeln('Минимальный элемент ',min,' и его номер ',mini)

end.

Или (если max или min элемент будет не один)

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

min:=a[1];

for i:= 1 to n do

begin

if a[i]>max then max:=a[i];

if a[i]

end;

writeln;

for i:= 1 to n do

begin

if a[i]=max then writeln('Максимальный элемент ',max,' и его номер ',i);

if a[i]=min then writeln('Минимальный элемент ',min,' и его номер ',i)

end

end.

(1.7k баллов)
0

спс

0

имя программы не забудьте написать

0

Зачем?

0

13 ниса 13 можешь помочь с задачями вот ссылка https://znanija.com/task/31076553 очень буду благодарен за эту помощью,