Паскаль срочно/!!!!!!! напишите программу которая заполняет массив из N=8 элементов...

0 голосов
68 просмотров

Паскаль срочно/!!!!!!! напишите программу которая заполняет массив из N=8 элементов случайными числами в диапазоне [0,20] , выводит его на экран, а затем меняет местами пары соеденёных элементов, кроме первого и последнего(2 с 3, 4с 5 и т. д.). Пример: Массив :5 16 2 13 3 14 18 17 Реверс:5 2 16 3 13 18 14 17


Информатика (12 баллов) | 68 просмотров
Дан 1 ответ
0 голосов

var

 a: array[1..10] of integer;

 i, n: integer;

begin

 n := 8;

 randomize;

 for i := 1 to N do

 begin

   a[i] := random(21);

   Write(a[i]:4);

 end;

 

 i := 2;

 while i

 begin

   Swap(a[i], a[i + 1]);

   i += 2

 end;

 

 Writeln;

 for i := 1 to N do

   Write(a[i]:4)

end.

(2.5k баллов)
0

Swap - процедура обмена в PascalABC.NET

0

procedure Swapl(var a, b: integer);var tmp: integer;begin tmp := a; a := b; b := tmpend;