** вход программы подаются произвольные алфавитно-цифровые символы. Ввод этих символов...

0 голосов
113 просмотров

На вход программы подаются произвольные алфавитно-цифровые символы. Ввод этих символов заканчивается точкой. Требуется напечатать последовательность строчных английских букв ('a' 'b'... 'z') из входной последовательности и частот их повторения. Печать должна происходить в алфавитном порядке. PYTHON входные данные fhbkbfshfm. выходные данные b 2 f 3 h 2 k 1 m 1 s 1


Информатика (32 баллов) | 113 просмотров
Дан 1 ответ
0 голосов

var s:string;

a:array['a'..'z'] of integer;

i:integer; c:char;

begin

writeln('Введите строку:');

readln(s);

for c:='a' to 'z' do a[c]:=0;

for i:=1 to length(s) do

 if (s[i]>='a')and(s[i]<='z') then a[s[i]]:=a[s[i]]+1;</p>

for c:='a' to 'z' do

 if a[c]>0 then writeln(c,' ',a[c]);

end.


(74 баллов)