Написать программу если число чётное то делим на 2 . Если ничтое то возводим В квадрат
var a: integer;
begin
readln(a);
if a mod 2=0 then writeln (a/2)
else writeln (sqr(a));
end.
Программа представлена на языке Pascal.