Нужен о написать программу в Pascal, помогите пожалуйста

0 голосов
49 просмотров

Нужен о написать программу в Pascal, помогите пожалуйста


image

Информатика (73 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

var

n,i: integer;

s: double;

begin

readln(n);

for i:=1 to n do

 s:=s+(1/i**3);

write(s);

end.

(489 баллов)
0

В программе ошибку выдаёт(

0

Странно у меня все работает, можешь ошибку скинуть?

0

Ты на freepascal?

0

Если на freepascal то вотuses math;varn,i: integer;s: double;beginreadln(n);for i:=1 to n do s:=s+(1/i**3);write(s:2:5);end.

0

Скачала другой, все заработало, спасибо)

0

Можешь ещё с одной программой помочь пожалуйста?) Дана квадратная матрица. Найти сумму главной диагонали и вычесть полученное число из всех элементов матрицы, больших данной суммы

0

varn,i,j, sum: integer;mas: array[1..100,1..100] of integer;beginsum:=0;readln(n);for i:=1 to n dobegin for j:=1 to n do read(mas[i,j]); readln;end;for i:=1 to n do inc(sum, mas[i,i]);for i:=1 to n do for j:=1 to n do if (mas[i,j]>sum) then dec(mas[i,j], sum);writeln('Вывод');for i:=1 to n dobegin for j:=1 to n do write(mas[i,j], ' '); writeln;end;end.

0

Если я конечно все правильно понял..