C++даны 5 чисел напишите программу которая выводит их в обратном порядке.В программе...

0 голосов
60 просмотров

C++даны 5 чисел напишите программу которая выводит их в обратном порядке.В программе подается 5 целых неотрецательных чисел числа не больше чем 100000. программс должна вывести "перевернутую" последовательность чисел не содержущую 0 C++


Информатика (654k баллов) | 60 просмотров
Дано ответов: 2
0 голосов

#include

#include

using namespace std;

int main()

{

int mas[5];

for(int i = 0; i < 5; i++){

 cout << "Input element[" << i << "] = "; cin >> mas[i];

 while(mas[i] < 0){

 cout << "Input element[" << i << "] = "; cin >> mas[i];

 }

}

cout

for(int i = 0; i < 5; i++){

 cout

}

cout

for(int i = 4; i >= 0; i--){

 if(mas[i] != 0){

 cout

 }

 

}

cout

system("pause");

return 0;

}

(3.4k баллов)
0 голосов

#include

#include

using namespace std;

int main()

{

string st;

cin>>st;

for(int i=0;i

{

if(s[i] == '0')

{

st=st.erase(i);

}

cout<<reverse(st)<<endl;</p>

system("pause");

return 0;

}

(106 баллов)
0

Забыл условие: || mas[i] > 100000 в цикле while