Напишите программу ** языке PascalРазведчики-математики для того, чтобы опознать своих,...

0 голосов
202 просмотров

Напишите программу на языке PascalРазведчики-математики для того, чтобы опознать своих, используют числовыепароли. Услышав число-пароль, разведчик должен возвести его в квадрат исказать в ответ первую цифры дробной части полученного числа. Напишитепрограмму, которая по полученному паролю (вещественному числу) вычисляетчисло-ответ.Пример:Введите пароль: 1.92Ответ: 6потому что 1,922 = 3,6864…, первая цифра дробной части – 6


Информатика (12 баллов) | 202 просмотров
Дан 1 ответ
0 голосов

Легче лёгкого:


program abc;

var

i:real;

s:string;

Begin

readLn(i);

i:= frac(i*i);

str(i,s);

write(s[3]);

End.

(28 баллов)
0

При вводе числа 1.92,в ответе выводит точку!? почему?

0

Упс. Мисс клик. Пробуйте

0

всё,спасибо