Написать программу на Паскале, используя цикл. Нужно ввести число, и программа должна выдать количество цифр в введённом числе.
begin Print(ReadlnInteger('n =').ToString.Count)end.
var i,N,t:integer;
BEGIN
readln(N);
N:=abs(N);
t:=0;
while N>0 do begin
t+=1;
N:=N div(10);
end;
writeln(t);
end.
var
a, n: Integer;
begin
Read(a);
a := Abs (a);
repeat
a := a div 10;
n := n + 1;
until a = 0;
Write(n);