Написать программу ** Паскале, используя цикл. Суть программы: вводится число, а...

0 голосов
31 просмотров

Написать программу на Паскале, используя цикл. Суть программы: вводится число, а программа определяет, каких цифр больше: чётных или нечётных.


Информатика (132 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

var n,k1,k2:integer;

begin

write ('Введите число: ');

readln(n);

while n>0 do

begin

if n mod 10 mod 2 = 0 then k2:=k2+1

else k1:=k1+1;

n:=n div 10

end;

if k1>k2 then write ('Нечётных цифр в числе больше')

else write ('Чётных цифр в числе больше')

end.

(1.7k баллов)