PascalABC.net Составить программу проверки, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, и уравнения окружности).
var x,y: real;
begin
readln(x,y);
if (x>=-6)and(x<=-3)and(y>=-3)and(y<=2)or</p>
(x>=-6)and(x<=-1)and(y>=2)and(y<=7)</p>
then writeln('Yes') else writeln('No');
end.
Пример:
-3 3
Yes
использовать формулы уравнения прямой, проходящей через две точки, и уравнения окружности
Вы на приведенном рисунке видите окружности? Или какие-то прямые кроме тех, что параллельны осям координат?