Дано натуральное число. Напишите программу, которая проверяет, является ли оно...

0 голосов
77 просмотров

Дано натуральное число. Напишите программу, которая проверяет, является ли оно трехзначным и кратно ли 7 сумма его цифр.


Информатика (12 баллов) | 77 просмотров
0

Язык определенный?

0

без данной информации и ответа не будет как бы

Дан 1 ответ
0 голосов

На Паскале это будет выглядеть следующим образом:

program num;

var a,b,i,sum: integer;

begin

sum:=0;

a:=0;

b:=0;

i:=0;

writeln('Enter your number ');

readln(a);

if ((a>99)  and (a<1000)) then begin</p>

writeln('It has 3 digits');

for i:=0 to 3 do begin *!!!если будет ошибка, то смени 3 на 2!!!*

b:=a mod 10;

a:=a div 10;

sum:=sum+b;

end *!!!тут спорный момент. Если будет ошибка, то спроси у учителя как правильно поставить точку с запятой =)!!!*else

writeln('You wrote a wrong number, try again!');

end; *!!!и еще раз - если будет ошибка компиляции, то спроси у учителя как правильно расставить точки с запятыми(;)!!!*

end.



(36 баллов)